re = /^(\D*\d+\D*)\d+/m
str = 'This 9 is 8 a 77 6 test'
subst = '$1hello'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result