#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(\D*\d+\D*)\d+"
Local $sString = "This 9 is 8 a 77 6 test"
Local $sSubst = "$1hello"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)