# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!\w)\d+(?<!\")//gms;t' <<< "
\"gnhgnghb grhgf ytjy 4444 rewgefgg gfbvc\" 234234 =2345234
sdhjaklf382as;ldfj asda2334= 76555
=123123
:1233
\"gnhgnghb grhgf ytjy4444 rewgefgg
gfbvc\"
\"gnhgnghb grhgf ytjy 4444 rewgefgg
gfbvc\""