const regex = /(?<!\w)\d+(?<!\")/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\w)\\d+(?<!\\")', 'gms')
const str = `
"gnhgnghb grhgf ytjy 4444 rewgefgg gfbvc" 234234 =2345234
sdhjaklf382as;ldfj asda2334= 76555
=123123
:1233
"gnhgnghb grhgf ytjy4444 rewgefgg
gfbvc"
"gnhgnghb grhgf ytjy 4444 rewgefgg
gfbvc"`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);