re = /(?<!\w)\d+(?<!\")/m
str = '
"gnhgnghb grhgf ytjy 4444 rewgefgg gfbvc" 234234 =2345234
sdhjaklf382as;ldfj asda2334= 76555
=123123
:1233
"gnhgnghb grhgf ytjy4444 rewgefgg
gfbvc"
"gnhgnghb grhgf ytjy 4444 rewgefgg
gfbvc"'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result