# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<!\w)\d+(?<!\")"
test_str = ("\n"
"\"gnhgnghb grhgf ytjy 4444 rewgefgg gfbvc\" 234234 =2345234\n"
"sdhjaklf382as;ldfj asda2334= 76555\n"
"=123123\n"
":1233\n\n"
"\"gnhgnghb grhgf ytjy4444 rewgefgg \n"
"gfbvc\"\n\n"
"\"gnhgnghb grhgf ytjy 4444 rewgefgg \n"
"gfbvc\"")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.