import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\w)\\d+(?<!\\\")";
final String string = "\n"
+ "\"gnhgnghb grhgf ytjy 4444 rewgefgg gfbvc\" 234234 =2345234\n"
+ "sdhjaklf382as;ldfj asda2334= 76555\n"
+ "=123123\n"
+ ":1233\n\n"
+ "\"gnhgnghb grhgf ytjy4444 rewgefgg \n"
+ "gfbvc\"\n\n"
+ "\"gnhgnghb grhgf ytjy 4444 rewgefgg \n"
+ "gfbvc\"";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}