using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\w)\d+(?<!\"")";
string substitution = @"";
string input = @"
""gnhgnghb grhgf ytjy 4444 rewgefgg gfbvc"" 234234 =2345234
sdhjaklf382as;ldfj asda2334= 76555
=123123
:1233
""gnhgnghb grhgf ytjy4444 rewgefgg
gfbvc""
""gnhgnghb grhgf ytjy 4444 rewgefgg
gfbvc""";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}