use strict;
my $str = '
"gnhgnghb grhgf ytjy 4444 rewgefgg gfbvc" 234234 =2345234
sdhjaklf382as;ldfj asda2334= 76555
=123123
:1233
"gnhgnghb grhgf ytjy4444 rewgefgg
gfbvc"
"gnhgnghb grhgf ytjy 4444 rewgefgg
gfbvc"';
my $regex = qr/(?<!\w)\d+(?<!\")/msp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";