#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?ms)(?<!\w)\d+(?<!\")"
Local $sString = "" & @CRLF & _
""gnhgnghb grhgf ytjy 4444 rewgefgg gfbvc" 234234 =2345234" & @CRLF & _
"sdhjaklf382as;ldfj asda2334= 76555" & @CRLF & _
"=123123" & @CRLF & _
":1233" & @CRLF & _
"" & @CRLF & _
""gnhgnghb grhgf ytjy4444 rewgefgg " & @CRLF & _
"gfbvc"" & @CRLF & _
"" & @CRLF & _
""gnhgnghb grhgf ytjy 4444 rewgefgg " & @CRLF & _
"gfbvc""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)