re = /^11,|,11\b/m
str = '11,22,33,44,55,111
22,33,11,44,55,111
22,33,44,55,111,11'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result