# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\s*|\s*$|\s*(\r?\n)\s*|(\s)\s+/$1$2/g;t' <<< "
Let's
make this
look
a little
nicer
and
more
readible
"