re = /^\s*|\s*$|\s*(\r?\n)\s*|(\s)\s+/
str = '
Let\'s
make this
look
a little
nicer
and
more
readible
'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result