package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\s*|\s*$|\s*(\r?\n)\s*|(\s)\s+`)
var str = `
Let's
make this
look
a little
nicer
and
more
readible
`
var substitution = "$1$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}