use strict;
my $str = '
Let\'s
make this
look
a little
nicer
and
more
readible
';
my $regex = qr/^\s*|\s*$|\s*(\r?\n)\s*|(\s)\s+/p;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";