using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*|\s*$|\s*(\r?\n)\s*|(\s)\s+";
string substitution = @"$1$2";
string input = @"
Let's
make this
look
a little
nicer
and
more
readible
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}