const regex = /^\s*|\s*$|\s*(\r?\n)\s*|(\s)\s+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*|\\s*$|\\s*(\\r?\\n)\\s*|(\\s)\\s+', 'g')
const str = `
Let's
make this
look
a little
nicer
and
more
readible
`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);