// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^\s*|\s*$|\s*(\r?\n)\s*|(\s)\s+").unwrap();
let string = "
Let's
make this
look
a little
nicer
and
more
readible
";
let substitution = "$1$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}