import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*|\\s*$|\\s*(\\r?\\n)\\s*|(\\s)\\s+";
final String string = "\n"
+ " Let's \n"
+ "make this\n"
+ " look\n\n"
+ " a little\n\n\n"
+ " nicer \n"
+ " and \n"
+ "more \n\n"
+ "readible\n\n\n";
final String subst = "$1$2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}