$re = '/^\s*|\s*$|\s*(\r?\n)\s*|(\s)\s+/';
$str = '
Let\'s
make this
look
a little
nicer
and
more
readible
';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;