#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^\((?:\(\d+\.\d(?: \d+)?\)(?: |(?=\)$)))+\)$"
Local $sString = "((1.0 4) (2.0 5) (33.2) (10.0 8))"
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)