import Foundation
let pattern = #"^\((?:\(\d+\.\d(?: \d+)?\)(?: |(?=\)$)))+\)$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"((1.0 4) (2.0 5) (33.2) (10.0 8))"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)