import re
regex = re.compile(r"^\((?:\(\d+\.\d(?: \d+)?\)(?: |(?=\)$)))+\)$")
test_str = "((1.0 4) (2.0 5) (33.2) (10.0 8))"
subst = " "
result = regex.sub(subst, test_str)
if result:
print(result)