import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\((?:\\(\\d+\\.\\d(?: \\d+)?\\)(?: |(?=\\)$)))+\\)$";
final String string = "((1.0 4) (2.0 5) (33.2) (10.0 8))";
final String subst = " ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}