$re = '/^\((?:\(\d+\.\d(?: \d+)?\)(?: |(?=\)$)))+\)$/';
$str = '((1.0 4) (2.0 5) (33.2) (10.0 8))';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;