const regex = /^\((?:\(\d+\.\d(?: \d+)?\)(?: |(?=\)$)))+\)$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\((?:\\(\\d+\\.\\d(?: \\d+)?\\)(?: |(?=\\)$)))+\\)$', 'g')
const str = `((1.0 4) (2.0 5) (33.2) (10.0 8))`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);