using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\((?:\(\d+\.\d(?: \d+)?\)(?: |(?=\)$)))+\)$";
string substitution = @" ";
string input = @"((1.0 4) (2.0 5) (33.2) (10.0 8))";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}