# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s*Page \d+ of \d+\s*//g;t' <<< "thisisaboutthen
Page 2 of 12
nowwearegoing
Page 3 of 12
"