import Foundation
let pattern = #"\s*Page \d+ of \d+\s*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
thisisaboutthen
Page 2 of 12
nowwearegoing
Page 3 of 12
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)