re = /\s*Page \d+ of \d+\s*/
str = 'thisisaboutthen
Page 2 of 12
nowwearegoing
Page 3 of 12
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result