use strict;
my $str = 'thisisaboutthen
Page 2 of 12
nowwearegoing
Page 3 of 12
';
my $regex = qr/\s*Page \d+ of \d+\s*/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";