// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\s*Page \d+ of \d+\s*").unwrap();
let string = "thisisaboutthen
Page 2 of 12
nowwearegoing
Page 3 of 12
";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}