using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s*Page \d+ of \d+\s*";
string substitution = @"";
string input = @"thisisaboutthen
Page 2 of 12
nowwearegoing
Page 3 of 12
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}