package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\s*Page \d+ of \d+\s*`)
var str = `thisisaboutthen
Page 2 of 12
nowwearegoing
Page 3 of 12
`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}