#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ""(\d+)""
Local $sString = "טקסט שיש בו פה ושם משפרים. כמו 21 ואפילו 45." & @CRLF & _
"על כל פנים יש פה מספרים מוקפים כמו "45678" ואפילו כמה כאלה "46546456456" אבל יש כאלה שלא!" & @CRLF & _
"כל הזכויות שמורות לתחומים.קום, 2018" & @CRLF & _
""
Local $sSubst = "#$1#"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)