import Foundation
let pattern = #""(\d+)""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
טקסט שיש בו פה ושם משפרים. כמו 21 ואפילו 45.
על כל פנים יש פה מספרים מוקפים כמו "45678" ואפילו כמה כאלה "46546456456" אבל יש כאלה שלא!
כל הזכויות שמורות לתחומים.קום, 2018
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = ##"#$1#"##
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)