import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"(\\d+)\"";
final String string = "טקסט שיש בו פה ושם משפרים. כמו 21 ואפילו 45.\n"
+ "על כל פנים יש פה מספרים מוקפים כמו \"45678\" ואפילו כמה כאלה \"46546456456\" אבל יש כאלה שלא!\n"
+ "כל הזכויות שמורות לתחומים.קום, 2018\n";
final String subst = "#$1#";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}