const regex = /"(\d+)"/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"(\\d+)"', 'g')
const str = `טקסט שיש בו פה ושם משפרים. כמו 21 ואפילו 45.
על כל פנים יש פה מספרים מוקפים כמו "45678" ואפילו כמה כאלה "46546456456" אבל יש כאלה שלא!
כל הזכויות שמורות לתחומים.קום, 2018
`;
const subst = `#$1#`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);