package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`"(\d+)"`)
var str = `טקסט שיש בו פה ושם משפרים. כמו 21 ואפילו 45.
על כל פנים יש פה מספרים מוקפים כמו "45678" ואפילו כמה כאלה "46546456456" אבל יש כאלה שלא!
כל הזכויות שמורות לתחומים.קום, 2018
`
var substitution = "#$1#"
fmt.Println(re.ReplaceAllString(str, substitution))
}