// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#""(\d+)""#).unwrap();
let string = "טקסט שיש בו פה ושם משפרים. כמו 21 ואפילו 45.
על כל פנים יש פה מספרים מוקפים כמו \"45678\" ואפילו כמה כאלה \"46546456456\" אבל יש כאלה שלא!
כל הזכויות שמורות לתחומים.קום, 2018
";
let substitution = "#$1#";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}