using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""(\d+)""";
string substitution = @"#$1#";
string input = @"טקסט שיש בו פה ושם משפרים. כמו 21 ואפילו 45.
על כל פנים יש פה מספרים מוקפים כמו ""45678"" ואפילו כמה כאלה ""46546456456"" אבל יש כאלה שלא!
כל הזכויות שמורות לתחומים.קום, 2018
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}