# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\"(\d+)\""
test_str = ("טקסט שיש בו פה ושם משפרים. כמו 21 ואפילו 45.\n"
"על כל פנים יש פה מספרים מוקפים כמו \"45678\" ואפילו כמה כאלה \"46546456456\" אבל יש כאלה שלא!\n"
"כל הזכויות שמורות לתחומים.קום, 2018\n")
subst = "#$1#"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.