# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\bwhere(?:(?:(?!where)[^][])*\[[^][]*])+\s*//g;t' <<< "where this condition and [this = 1] group by 1,2,3
where that and that do that where [this = 1] and [that = 1] group by 1,2,3"