import Foundation
let pattern = #"\bwhere(?:(?:(?!where)[^][])*\[[^][]*])+\s*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
where this condition and [this = 1] group by 1,2,3
where that and that do that where [this = 1] and [that = 1] group by 1,2,3
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)