#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\bwhere(?:(?:(?!where)[^][])*\[[^][]*])+\s*"
Local $sString = "where this condition and [this = 1] group by 1,2,3" & @CRLF & _
"where that and that do that where [this = 1] and [that = 1] group by 1,2,3"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)