# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\bwhere(?:(?:(?!where)[^][])*\[[^][]*])+\s*"
test_str = ("where this condition and [this = 1] group by 1,2,3\n"
"where that and that do that where [this = 1] and [that = 1] group by 1,2,3")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.