re = /\bwhere(?:(?:(?!where)[^][])*\[[^][]*])+\s*/
str = 'where this condition and [this = 1] group by 1,2,3
where that and that do that where [this = 1] and [that = 1] group by 1,2,3'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result