import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bwhere(?:(?:(?!where)[^][])*\\[[^][]*])+\\s*";
final String string = "where this condition and [this = 1] group by 1,2,3\n"
+ "where that and that do that where [this = 1] and [that = 1] group by 1,2,3";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}