const regex = new RegExp('\\bwhere(?:(?:(?!where)[^][])*\\[[^][]*])+\\s*', 'g')
const str = `where this condition and [this = 1] group by 1,2,3
where that and that do that where [this = 1] and [that = 1] group by 1,2,3`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);