$re = '/\bwhere(?:(?:(?!where)[^][])*\[[^][]*])+\s*/';
$str = 'where this condition and [this = 1] group by 1,2,3
where that and that do that where [this = 1] and [that = 1] group by 1,2,3';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;